DB 990A Implematic Hydraulics Not Working

The place to discuss all matters relating to David Brown Tractors. You will need to register your user name before you can post. If you have already registered could you please make sure that your location details have been completed. Go to My Account in the Main Menu on the left, and then go into "Edit Your Information" and complete your location details. Give the Country (and State/Province if you wish) if outside the U.K. County if within the U.K. Location details helps other members if you need spares, technical advice, or the nearest practical help.

DISCLAIMER -

David Brown Tractor Club Ltd
Forum/website Disclaimer

1. This [forum/website/chat room] and the advice and opinions expressed herein is not a solution for mechanical, electrical, valuations, other problems, breakdowns or issues experienced in relation to the vehicles referenced.

2. If reliance is thought to be placed on any of the information guidance or input provided such information will be expressly confirmed as appropriate to be relied upon.

3. In the absence of any such confirmation no reliance should be suggested or inferred.

4. Members must not disclose information to 3rd parties in anticipation that reliance will be given by non-members.

5. Non-members must not purport to give advice on behalf of David Brown Tractor Club.

6. If you or someone you know is experiencing difficulties or repeated breakdowns you must seek assistance for an appropriately qualified expert who holds themselves out as such.

7. Any comments are free of charge and made or posted on an ex gratia basis. No member or non-member may advertise their professional services

Any user inactive for more than 3 months will automatically be deactivated, please contact admin@dbtc.co.uk if you would like to be reactivated.

Please be aware that your user name and entered location can be seen by all members. We only store information you have entered which is your email address and username, your IP is also stored, we have no access to private passwords.

If you do not agree with your information being stored, please do not register an account, If you wish to unsubscribe at any time please email admin@dbtc.co.uk giving your username.

Amended 27/10/18

Moderators: Segrie61, admin

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Wed Dec 04, 2019 4:10 pm

Hi
After dealing with the locked 3pt hitch problem in my earlier post, I was able to get the implement to raise and lower properly. I was experimenting with the lever to see how things would work and it was behaving pretty much as I had expected. Still a lot to learn though.

However, the tractor stalled out on me with the implement (snow blower) about 3 inches off the ground. I finally figured out how to vent the fuel system and get the machine started again after a couple days of cold weather.
But now the hydraulics do not move at all. I cannot raise or lower the snow blower - and I need it!

So a couple of questions.
1) If I have a problem with the pump and or filter screen, shouldn't the return lines still allow the implement to be lowered?
2) Does the ram allow the implement to be raised by other factors (i.e. the ground level pushing up on the snow blower) or does it apply down pressure?

I've had issues with the hydraulics to the loader which I haven't bothered working on yet as that is a low priority for me. I need to get the snow blower functional. I can use it but it leaves 3 inches of snow in the driveway right now. The loader is still not doing anything, so it could be a pump or filter issue. I have a 2 way diverter that seems to be moving properly when I remove the handle. I can pull it out and push it in. Neither position makes any change.

Is there a way I can release the pressure on the ram to lower the snow blower? Can I run it like that without damaging the ram? The blower has skid plates that will allow it to follow the ground contours, but if the ram is locked with a downward pressure will that cause problems?

The fluid level is good. I'm not sure what it should look like, but it seems clear and clean to me. I've read lots about milky fluid indicating water, but I don't think it is. I can read the markings on the dipstick through the fluid.

I'm not hearing any difference in noise when I try to raise or lower the hitch. I used to when it was working, but I don't have much experience with the noises it should be making.

Thanks for any help!
Bill

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Wor

Post by db2d » Wed Dec 04, 2019 6:25 pm

There is no downward pressure pressure on the rear linkage— lift and hold only.
The linkage is free t
The filters and pumping mechanism will not stop the lift from lowering.

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

Re: DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Wed Dec 04, 2019 6:49 pm

Thanks db2d!

Is it possible that there is a blockage in the ram cylinder that is blocked somehow? I can't see any other cause for both up and down not to work although I can't rule out multiple problems simultaneously.

Thanks
Bill

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Wed Dec 04, 2019 7:15 pm

It is extremely unlikely that a blockage in the ram cylinder is the cause of the problem on your tractor.
From the explanations you have given I suspect a valve is closed and not allowing oil to and from the ram cylinder. To operate the system the two way valve has to be closed to external services ( loader ) and controlled by the tractor hydraulic lever.
What is this diverting valve you mentioned?

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

Re: DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Wed Dec 04, 2019 7:42 pm

The diverter is where most of the documents show the 3 taps on the left side by the seat. It is a single tap. You actually helped me with this a week ago and I need to find a castellated nut to fit on it, but I manually move the valve in or out and it doesn't work either way (loader or 3 pt hitch)

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Wed Dec 04, 2019 8:33 pm

The valve does divert the oil either to the ram cylinder or loader. It is not a spool valve and works like a tap, the knob has to be turned either fully in or out. The valve will not divert the oil without the nut in the centre of the knob being in place.
It is possible that there is a problem with the linkages between the control lever and the pump valve chest.
Remove the plug on top of the PTO unit and check that the threaded rod is moving up and down when the control lever is being operated.

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Wed Dec 04, 2019 9:14 pm

As a quick fix to lower the linkage, fit the sensing cable onto the top link but be careful whilst doing this as the snow blower may drop suddenly. Fit the cable with the control lever fully back in the raise position and then move it forward to lower.

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

Re: DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Thu Dec 05, 2019 2:04 am

Thanks db2d

My top link is not the original, so I'm not sure if I can hook up the cable (which the previous owner never used so it's likely seized 8-(

I'll definitely check the plug on top of the PTO unit and see what is in there tomorrow.

Thanks
Bill

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Thu Dec 05, 2019 8:16 am

Extending the cable with the control lever in the lowering position will move a spool valve and the snow blower should lower. You can do this without fitting the cable onto the top link.

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

Re: DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Thu Dec 05, 2019 9:57 pm

I was unable to get the cable to move - it is seized pretty good. I did look in the opening for the PTO cover and it seems that the rod is moving up and down. It is the one directly under the port, correct?

I eventually decided to take the load off the lift arms and disconnect them from the ram shaft. Then I lowered the snow blower to the ground and ran it like that for a bit. It worked great until I got to a slight incline with a layer of glare ice under the snow. I couldn't get the tractor moving forward with the blower down. I had to unhook the blower to get the tractor to move again 8=(

So, now I have the snow blower stuck (at least it's not in the way). It does give me better access to the hydraulics now to sort that out.

Wish me luck!

And any advice or tips are still appreciated.

Bill

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Thu Dec 05, 2019 10:44 pm

Is the lever on the right hand side of the ramshaft out towards the mudguard and down ?
Remove the cover and check the operation of the trip mechanism by operating the lever by
lifting the lever until it connects with the operating pivot and then up further to trip the linkage.
Do this a few times to familiarise yourself with the trip operation.

LoneWolfMuskoka
Posts: 19
Joined: Sun Sep 15, 2019 3:18 am
Location: Canada

Re: DB 990A Implematic Hydraulics Not Working

Post by LoneWolfMuskoka » Fri Dec 06, 2019 10:33 pm

I didn't have a chance to get to the tractor today so I'll be working on it tomorrow. I did some reading though, and while I can see how to drain the oil and remove the mesh, I'm not seeing anywhere that describes how to refill it. It doesn't go back in through the dipstick opening does it?

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Fri Dec 06, 2019 11:08 pm

The easiest method to fill the gearbox with oil is to remove the cover on top of the PTO unit and simply pour it in.

Gard
Posts: 257
Joined: Sun Apr 06, 2008 2:25 pm
Location: Fairfax Vermont USA

Re: DB 990A Implematic Hydraulics Not Working

Post by Gard » Fri Dec 06, 2019 11:16 pm

there is a large plug, guessing about 1" on the right front side of the transmission cover, I usually add oil there, in my case there is a return from the loader going in there. There is another plug with a square recess in the back, on top of the PTO transmission if I remember correctly. I guess you could pour it in any convenient plug.

It sounds like the hydraulics worked until it got cold, so perhaps there is some moisture in the system someplace that froze up. You should probably change the oil when it is warm enough so any water will drain out. When I first took out the drain plug on a new to me tractor nothing came out because there was an inch or 2 of water in the bottom. Most likely the water came in from the damaged gear shift gaiters. I also suspect there was water in the 3ph linkage mechanism (piston and housing broken).

User avatar
db2d
Posts: 2126
Joined: Fri Feb 24, 2012 10:01 pm
Location: Monmouthshire

Re: DB 990A Implematic Hydraulics Not Working

Post by db2d » Fri Dec 06, 2019 11:40 pm

Some form of heating may be necessary, or a warm environment to warm the oil, and thaw any water that maybe present.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests