david brown 900

This is for members to post photos of their restorations, either completed or "works in progress"

Moderators: Segrie61, admin

Post Reply
greasybert123
Posts: 27
Joined: Thu Jan 10, 2019 6:20 pm
Location: merseyside

david brown 900

Post by greasybert123 » Tue Aug 13, 2019 5:42 pm

anybody help,had all the cylinder head done new piston rings new big end shells put
it all back together run it got it hot still leaking oil out of the exhaust manifold :(

blissakpo
Posts: 76
Joined: Tue Jul 17, 2018 7:15 pm
Location: IRAQ

Re: david brown 900

Post by blissakpo » Tue Aug 13, 2019 8:44 pm

While you had it to bits did you replace the inlet valve rubber seals?

greasybert123
Posts: 27
Joined: Thu Jan 10, 2019 6:20 pm
Location: merseyside

Re: david brown 900

Post by greasybert123 » Wed Aug 14, 2019 12:03 pm

yes all the valve seals have been done i,ve been told it wants runing, to bed in if thats normal. :x

User avatar
bedwards1966
Posts: 877
Joined: Sun Mar 07, 2010 10:36 pm
Location: North Yorkshire

Re: david brown 900

Post by bedwards1966 » Fri Aug 16, 2019 5:15 pm

You can get oil coming out of the exhaust when it hasn't bedded in, the other possibility is that an inlet seal or oil ring has been fitted wrong.

Give the tractor some hard work - a heavy trailer on hills is good, use engine braking to slow it down when going down hill. Avoid very high revs and avoid constant revs like prolonged PTO work. It'll probably be all that it needs.

Why was it taken apart, what was the initial problem?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests