885 loader hydraulics problem

The place to discuss all matters relating to David Brown Tractors. You will need to register your user name before you can post. If you have already registered could you please make sure that your location details have been completed. Go to My Account in the Main Menu on the left, and then go into "Edit Your Information" and complete your location details. Give the Country (and State/Province if you wish) if outside the U.K. County if within the U.K. Location details helps other members if you need spares, technical advice, or the nearest practical help.

DISCLAIMER -

David Brown Tractor Club Ltd
Forum/website Disclaimer

1. This [forum/website/chat room] and the advice and opinions expressed herein is not a solution for mechanical, electrical, valuations, other problems, breakdowns or issues experienced in relation to the vehicles referenced.

2. If reliance is thought to be placed on any of the information guidance or input provided such information will be expressly confirmed as appropriate to be relied upon.

3. In the absence of any such confirmation no reliance should be suggested or inferred.

4. Members must not disclose information to 3rd parties in anticipation that reliance will be given by non-members.

5. Non-members must not purport to give advice on behalf of David Brown Tractor Club.

6. If you or someone you know is experiencing difficulties or repeated breakdowns you must seek assistance for an appropriately qualified expert who holds themselves out as such.

7. Any comments are free of charge and made or posted on an ex gratia basis. No member or non-member may advertise their professional services

Any user inactive for more than 3 months will automatically be deactivated, please contact admin@dbtc.co.uk if you would like to be reactivated.

Please be aware that your user name and entered location can be seen by all members. We only store information you have entered which is your email address and username, your IP is also stored, we have no access to private passwords.

If you do not agree with your information being stored, please do not register an account, If you wish to unsubscribe at any time please email admin@dbtc.co.uk giving your username.

Amended 27/10/18

Moderators: Segrie61, admin

Post Reply
ScottUSA
Posts: 50
Joined: Mon Mar 26, 2018 1:59 pm
Location: North Carolina

885 loader hydraulics problem

Post by ScottUSA » Mon Nov 26, 2018 6:26 pm

Dunham-Lehr 22 loader on an 885. Loader has what I believe is called an "open center spool valve" for the loader control. The camel hump has been replaced with a steel plate with two ports (hoses). If the loader is removed from the tractor the hoses must be connected at the tractor to keep from dead-heading the hydraulic pump. New hydraulic filter, fluid, etc. about 17 hours ago. Olleck set me straight on the correct select-o-matic settings a few months back. Everything has been working just fine until a week ago.

The problem is the loader occasionally fails to respond to the controls. When this happens the 3-point still works. If the loader bucket is up and loaded it just sits there, if it is on the ground, same thing; no dump/roll-back/float/up/down, nothing. Shut the tractor off and wait a few minutes, restart and everything is back to working like normal. Noticed yesterday that if, when the loader fails to cooperate, if the quadrant lever is momentarily moved to the "select" position (to unlock the lift lock) when the bypass valve opens (squeals) the loader goes right back to working. This issue is new and has gone never to happening every time the tractor is used in just over an hour of loader use.

ScottUSA
Posts: 50
Joined: Mon Mar 26, 2018 1:59 pm
Location: North Carolina

Re: 885 loader hydraulics problem

Post by ScottUSA » Thu Nov 29, 2018 6:35 pm

Certainly this isn't that challenging a problem for you long term David Brown owners to offer a suggestion? Just kidding, I've not come up with a thing... it won't stay not working long enough to attempt to identify the problem. Reviewing flow schematics of the hydraulic system hasn't led to any conclusions and frankly, I do not know where to start looking. I am not well heeled enough in things David Brown to make an educated guess so it's all head scratching for me.

jazo
Posts: 753
Joined: Fri Jun 15, 2007 7:13 am
Location: New Zealand

Re: 885 loader hydraulics problem

Post by jazo » Thu Nov 29, 2018 7:27 pm

If it is connected as you say, it is impossible for the loader not to work and the 3pl to work unless it is something to do with your loader valve
1394 4wd
1294 4wd
30D
990x2
780x2
900

User avatar
ollek
Posts: 3564
Joined: Tue Apr 10, 2012 1:20 pm
Location: South West Finland

Re: 885 loader hydraulics problem

Post by ollek » Thu Nov 29, 2018 8:00 pm

As said before, if the 3-point hitch is working but the loader not, then the fault is in the loader valve, not in the tractor. This is if the plumbing and the problem is as told. The loader and the loader valve are US manufactured products and it must therefor be possible for the loader valve manufacturer to sort the problem.

ScottUSA
Posts: 50
Joined: Mon Mar 26, 2018 1:59 pm
Location: North Carolina

Re: 885 loader hydraulics problem

Post by ScottUSA » Fri Nov 30, 2018 6:38 pm

Thanks! I'll contact to manufacturer of the valve.

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests