780 selectamatic loader spool challenge...

The place to discuss all matters relating to David Brown Tractors. You will need to register your user name before you can post. If you have already registered could you please make sure that your location details have been completed. Go to My Account in the Main Menu on the left, and then go into "Edit Your Information" and complete your location details. Give the Country (and State/Province if you wish) if outside the U.K. County if within the U.K. Location details helps other members if you need spares, technical advice, or the nearest practical help.

DISCLAIMER -

David Brown Tractor Club Ltd
Forum/website Disclaimer

1. This [forum/website/chat room] and the advice and opinions expressed herein is not a solution for mechanical, electrical, valuations, other problems, breakdowns or issues experienced in relation to the vehicles referenced.

2. If reliance is thought to be placed on any of the information guidance or input provided such information will be expressly confirmed as appropriate to be relied upon.

3. In the absence of any such confirmation no reliance should be suggested or inferred.

4. Members must not disclose information to 3rd parties in anticipation that reliance will be given by non-members.

5. Non-members must not purport to give advice on behalf of David Brown Tractor Club.

6. If you or someone you know is experiencing difficulties or repeated breakdowns you must seek assistance for an appropriately qualified expert who holds themselves out as such.

7. Any comments are free of charge and made or posted on an ex gratia basis. No member or non-member may advertise their professional services

Any user inactive for more than 3 months will automatically be deactivated, please contact admin@dbtc.co.uk if you would like to be reactivated.

Please be aware that your user name and entered location can be seen by all members. We only store information you have entered which is your email address and username, your IP is also stored, we have no access to private passwords.

If you do not agree with your information being stored, please do not register an account, If you wish to unsubscribe at any time please email admin@dbtc.co.uk giving your username.

Amended 27/10/18

Moderators: Segrie61, admin

User avatar
GeoffDEAL
Posts: 411
Joined: Tue Jan 27, 2009 8:25 am
Location: New Zealand

Re: 780 selectamatic loader spool challenge...

Post by GeoffDEAL » Sat Jan 26, 2019 12:50 am

By the photos the return hoses come back to the spool valve, any return should dump back to a suitable connection to the gearbox this applies to using a double acting valve on a single acting cylinder or cylinders. The same applies when using a single cylinder on remote double acting plug ins the second side has to have a return dump hose pluged in for it to work single ram . Hope this helps sort it out cheers Geoff .

philedge
Posts: 235
Joined: Sun Dec 03, 2006 11:27 am
Location: Chester UK

Re: 780 selectamatic loader spool challenge...

Post by philedge » Sun Jan 27, 2019 11:09 pm

GeoffDEAL wrote:
Sat Jan 26, 2019 12:50 am
By the photos the return hoses come back to the spool valve, any return should dump back to a suitable connection to the gearbox this applies to using a double acting valve on a single acting cylinder or cylinders. The same applies when using a single cylinder on remote double acting plug ins the second side has to have a return dump hose pluged in for it to work single ram . Hope this helps sort it out cheers Geoff .
Maybe I missing what you are saying, but the return from the spool block is already plumbed into the gearbox as in one of the OPs photos. Theres no dedicated returns from the rams to the spool block as all pipes to the rams are both flow and return pipes, so these pipes have to be connected to the spool block
'66 880 Selectamatic rat.

tomryall
Posts: 148
Joined: Sun Jun 03, 2007 4:53 am
Location: canada

Re: 780 selectamatic loader spool challenge...

Post by tomryall » Sun Jan 27, 2019 11:22 pm

if the loader lift rams are single acting and the spool is double then you need a return from the blanked outlet on that spool to the gearbox.
do you know if the spool valve is open or closed centre if it is closed centre then it will not work on a DB.

davebirt
Posts: 12
Joined: Tue Jan 01, 2019 11:11 am
Location: somerset

Re: 780 selectamatic loader spool challenge...

Post by davebirt » Wed Jan 30, 2019 8:29 pm

success!

The problem seemed to be that oil was rising from both return points on the tractor axle (left and right hand sides) the chap who very kindly helped me sort this, then popped a jet of compressed air into the return inlet on the tractor (right hand side of the seat), we both scratched our heads as we heard the air cleanly enter the transmission and couldn't figure why oil was rising (this was the last thing we did after loads of other checks) so we connected it up again and hey presto it worked. The oil being allowed to return to the tractor from this port after a shot of air.

Thank you for all of your opinions and help.

Now anyone got a david brown 780 bucket?!

SteveCollett
Posts: 570
Joined: Wed Sep 24, 2008 8:17 am
Location: Suffolk

Re: 780 selectamatic loader spool challenge...

Post by SteveCollett » Thu Jan 31, 2019 10:44 am

very glad you are sorted, sounds as though their was some sort of blockage in there

philedge
Posts: 235
Joined: Sun Dec 03, 2006 11:27 am
Location: Chester UK

Re: 780 selectamatic loader spool challenge...

Post by philedge » Fri Feb 01, 2019 11:29 am

Thats a strange scenario! If the return pipe was fully blocked then pressure in the spool valve would rise to pump pressure and youd hear the pump straining as it pumped against a dead end. If the return was partially blocked the lift and tip would both work but only slowly depending on how blocked the return was. Strange.

If theres been a blockage thats now cleared, whatever it was is likely in the gearbox so probably worth dropping the oil and checking the oil/sump/filter for debris??
'66 880 Selectamatic rat.

davebirt
Posts: 12
Joined: Tue Jan 01, 2019 11:11 am
Location: somerset

Re: 780 selectamatic loader spool challenge...

Post by davebirt » Fri Feb 01, 2019 5:36 pm

umm that's a ************- have just changed the oil and filter :roll:

philedge
Posts: 235
Joined: Sun Dec 03, 2006 11:27 am
Location: Chester UK

Re: 780 selectamatic loader spool challenge...

Post by philedge » Fri Feb 01, 2019 10:31 pm

Just dump the oil in a clean container and reuse all but the last dregs. Its just a precautionary suggestion but I think worth doing if you dont know what the blockage was
'66 880 Selectamatic rat.

davebirt
Posts: 12
Joined: Tue Jan 01, 2019 11:11 am
Location: somerset

Re: 780 selectamatic loader spool challenge...

Post by davebirt » Tue Feb 05, 2019 5:24 pm

:D ok will do.

Post Reply

Who is online

Users browsing this forum: Majestic-12 [Bot] and 10 guests